650Rider, xs650 hosted by XS650.com

What Happened to 650rider.com?

650 Rider went offline for about a month at the beginning of 2010. In order to save the technical information that was here, XS650.com acquired the site and brought it back online as a read-only archive. If you were a member of 650 Rider, you will need to re-register at XS650.com

     [x] 650Rider Menu
 Community Search Information


xs650 > > After Market Products > > Pamco - Electronic Ignitions > > Pamco Ignition - No spark, anyone else?

SearchSearch


Pamco Ignition - No spark, anyone else?
Go to page Previous  1, 2
    Forum Index -> Pamco - Electronic Ignitions
View previous topic :: View next topic  
Author Message
pamcopete
650Rider Supporter
650Rider Supporter


Joined: Oct 10, 2008
Posts: 875
Location: South Carolina

PostPosted: May 24, 2009, 8:48 pm    Post subject: Re: Pamco Ignition - No spark, anyone else?

Tee Cat

The symptoms are that it just quits. I trhink that you probably have some other problem, but it wouldn't hurt to strip the insulation off of the ends of the coil.

_________________
Ride.Enjoy.Life is simple
Back to top
buckroseau
Full Member
Full Member


Joined: Apr 22, 2007
Posts: 42
Location: Northern Minnesota

PostPosted: May 25, 2009, 8:47 pm    Post subject: Re: Pamco Ignition - No spark, anyone else?

Pete,

I got my new Pamco unit from Mikesxs on Friday. Friday evening I had my electrical engineering buddy crimp new ends on the unit, along with a 6 amp inline fuse. Got everything installed again Friday night and it fired right up.

I got a chance to ride it this weekend, got about 30+ miles on Sunday, no problems to speak of...at least not with the ignition Smile

Hopefully more miles to come in the next few days and weeks...I'll keep you posted.

Thanks, Matt
Back to top
Photo Gallery
pamcopete
650Rider Supporter
650Rider Supporter


Joined: Oct 10, 2008
Posts: 875
Location: South Carolina

PostPosted: May 27, 2009, 8:15 am    Post subject: Re: Pamco Ignition - No spark, anyone else?

buckroseau

Great! Hope you read the above post regarding overheating coils and the correct way to mount them for cooling.

_________________
Ride.Enjoy.Life is simple
Back to top
TeeCat
Full Member
Full Member


Joined: Aug 21, 2007
Posts: 1120
Location: Central Maryland

PostPosted: May 27, 2009, 10:37 am    Post subject: Re: Pamco Ignition - No spark, anyone else?

Pete, thank you... as it turns out, I had fouled plugs, likely from too much idling time while i work on it. Sad

So, when I get a chance... maybe just cut the insulation off the mounting ears with a knife or something? I seem to recall it being molded on. And it won't hurt to have the ears being in direct contact with the mounting surfaces of the frame?

Hey... piccies of that (ideal mounting) might be a good addition/update to your website!

TC
Back to top
Photo Gallery
pamcopete
650Rider Supporter
650Rider Supporter


Joined: Oct 10, 2008
Posts: 875
Location: South Carolina

PostPosted: May 27, 2009, 11:26 am    Post subject: Re: Pamco Ignition - No spark, anyone else?

TeeCat

Yes, just strip the insulation off of the top and bottom of the ends where the bolt holes are. The idea is to provide direct metal to metal contact with the mounting clamps for better heat conduction.

I have posted the mounting technique on my web site. Just click where it says "Installing the coils on '72 to '79 models"

www.yamahaxs650.com

_________________
Ride.Enjoy.Life is simple
Back to top
TeeCat
Full Member
Full Member


Joined: Aug 21, 2007
Posts: 1120
Location: Central Maryland

PostPosted: May 27, 2009, 12:23 pm    Post subject: Re: Pamco Ignition - No spark, anyone else?

Aaaah... good! Thanks for that addition. I'll be getting to that as soon as I get some spare time.

TC
Back to top
Photo Gallery
buckroseau
Full Member
Full Member


Joined: Apr 22, 2007
Posts: 42
Location: Northern Minnesota

PostPosted: September 22, 2009, 9:25 am    Post subject: Re: Pamco Ignition - No spark, anyone else?

Just a FYI....a 6 amp inline fuse will not blow if the ignition switch is left on, per the previous post(s). In my case it either shorted out the coil or pamco unit or both.....again. I tried a smaller fuse, but it seems to pop the fuse when the ignition is turned on. Ended up ordering another new one from Mikesxs, works fine again.

I'm more mad at myself than anything....just thought I would post that info up for anyone else wondering?

Matt
Back to top
Photo Gallery
Imcgyver
Full Member
Full Member


Joined: Jun 25, 2008
Posts: 15

PostPosted: November 30, 2009, 7:27 pm    Post subject: Re: Pamco Ignition - No spark, anyone else?

Hello, this question is for buckroseau, I also have an81H and looking at the Pamco setup with rhe green coil, Will the coil mount on the factory frame mount or will I need to get the ground clamps?
Thank you for your time and response Ron
Back to top
pumps
650Rider Supporter
650Rider Supporter


Joined: May 29, 2007
Posts: 1993
Location: Kansas City, Missouri, U.S.A.- 1977 XS650 "D" Standard

PostPosted: November 30, 2009, 8:30 pm    Post subject: Re: Pamco Ignition - No spark, anyone else?

Imcgyver- Read this from Pete's site, linked above in his post.
Pictures!
www.yamahaxs650.com/Gr...20Coil.htm

_________________
You don't HAVE to be crazy to run into burning buildings, but it HELPS!
On an XS you won't pass yourself on the road everyday. Wink

My Bikes
Back to top
Photo Gallery
pamcopete
650Rider Supporter
650Rider Supporter


Joined: Oct 10, 2008
Posts: 875
Location: South Carolina

PostPosted: December 1, 2009, 6:51 am    Post subject: Re: Pamco Ignition - No spark, anyone else?

imcg,

The green monster coil will mount in the stock bracket in '80 to '83 models using the standoffs that come with the coil. It is important that you mount the coil to clear the tank on both sides, like this:


_________________
Ride.Enjoy.Life is simple
Back to top
Imcgyver
Full Member
Full Member


Joined: Jun 25, 2008
Posts: 15

PostPosted: December 1, 2009, 12:03 pm    Post subject: Re: Pamco Ignition - No spark, anyone else?

Thank you for your response, the picture is a great help.
Back to top
Display posts from previous:   
Printer Friendly Page     Forum Index -> Pamco - Electronic Ignitions All times are GMT - 5 Hours
Go to page Previous  1, 2
Page 2 of 2


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


   

Check out the new Honda CB750 Forum at CB750.com! A site dedicated to the great Honda SOHC and DOHC CB750.

Check out the new Yamaha XS400 Forum at XS400.com!

Yamaha xs650

xs650, xs, 650, forum, links, chopper, custom, yamaha, parts, forum, info, information, bb, bulletin board, XS650
650Rider, Free Unrestricted xs650 forum, Personal photo albums, Post images in Forum, News columns, Daily blog, Links, Event calendar, Information for Yamaha XS650



Interactive software released under GNU GPL, Code Credits, Privacy Policy